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10.Δημοσίευση της ταινίας Flash στο web 
 

Βελτιστοποίηση περιεχομένων στο Flash 

 

Τόσο στις απλές ιστοσελίδες όσο και σε αυτές που είναι κατασκευασμένες με flash, πρέπει 

να φροντίζουμε ώστε το μέγεθος των αρχείων να είναι όσο το δυνατόν μικρότερο. Παρ’ όλο 

που οι ταχύτητες του internet έχουν αυξηθεί τα τελευταία χρόνια, το μέγεθος των αρχείων 

παίζει σημαντικό ρόλο επειδή επηρεάζει την απόδοση των περιεχομένων της σελίδας. Η 

διαδικασία αυτή είναι γνωστή ως βελτιστοποίηση των περιεχομένων του flash. 

Οι ακόλουθοι γενικοί κανόνες θα σας βοηθήσουν στο να βελτιστοποιήσετε τα περιεχόμενα 

του flash: 

 Χρησιμοποιείστε στιγμιότυπα για κάθε αντικείμενο το οποίο εμφανίζεται πολλές 

φορές. Είναι προτιμότερο να έχετε λίγα σύμβολα και πολλά στιγμιότυπα παρά 

πολλά σύμβολα. 

 Όταν δημιουργείτε κίνηση, χρησιμοποιήστε motion  tween όπου είναι εφικτό. Η 

τεχνική αυτή μειώνει το μέγεθος του αρχείου σε σχέση με την συμβατική κίνηση 

καρέ-καρέ ή το shape tween. 

 Στην κίνηση, χρησιμοποιήστε movie clips αντί σύμβολα γραφικών – graphic 

symbols. 

 Φροντίστε έτσι ώστε η περιοχή στην οποία γίνεται κάποια αλλαγή να είναι μικρή σε 

έκταση. 

 Αποφύγετε να δίνετε κίνηση σε γραφικά bitmap. Χρησιμοποιήστε τα γραφικά 

αυτά στο παρασκήνιο ως στατικά. 
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Βελτιστοποιώ ντας Εικο νες 

Οι εικόνες στο Flash αποτελούν μια πολύ καλή ευκαιρία βελτιστοποίησης του μεγέθους του 

παραγόμενου αρχείου. 

Τα ειδικά γεμίσματα και τα εφέ αυξάνουν το μέγεθος της παραγόμενης ταινίας. 

Χρησιμοποιήστε τα ακόλουθα tips για να βελτιστοποιήσετε αυτά τα χαρακτηριστικά. 

 Χρησιμοποιήστε την περιοχή Color Effect του properties inspector, για να 

δημιουργήσετε διαφορετικά εφέ σε ένα στιγμιότυπο, από το να δημιουργήσετε εφέ 

σε πολλά σύμβολα. 

 Να είστε φειδωλοί στην χρήση διαβαθμισμένων χρωμάτων (gradients). Περιορίστε 

τον αριθμό των ταυτόχρονων διαβαθμίσεων σε έναν μεμονωμένο καρέ. 

 Γεμίζοντας μια περιοχή με διαβαθμισμένο χρώμα απαιτεί 50 bytes περισσότερα 

από ότι απαιτεί ένα απλό χρώμα. Τα διαβαθμισμένα χρώματα επιβαρύνουν ακόμα 

και τον επεξεργαστή του υπολογιστή σε σχέση με τα απλά χρώματα. 

 Να είστε φειδωλοί και στην χρήση του alpha transparency επειδή επιβραδύνεται η 

αναπαραγωγή της ταινίας. 

 

Βελτιστοποιώντας εικόνες bitmaps 

Μία εικόνα bitmap καταλαμβάνει περισσότερο χώρο από μια εικόνα vector η οποία είναι η 

εξ’ ορισμού μορφή εικόνας στο flash. Όλες οι εικόνες οι οποίες εισάγονται στο flash, όπως 

οι JPEG, GIF και BMP είναι εικόνες bitmap. Το ίδιο ισχύει και για τις φωτογραφίες.  

Όταν παράγετε κίνηση σε μία εικόνα bitmap, το flash τοποθετεί την εικόνα αυτή σε κάθε 

καρέ της κίνησης. Επιπλέον μία εικόνα bitmap δεν μπορεί να περιστραφεί, ούτε να 

τροποποιηθεί το μέγεθος της σωστά, σε αντίθεση με τις εικόνες vector. Επί πρόσθετα, μία 

εικόνα bitmap πρέπει να περάσει από την διαδικασία του rendering κάθε φορά που αλλάζει 

θέση στο σκηνικό.  

 Όλα αυτά συνεπάγονται την βραδεία αναπαραγωγή της ταινίας σας όπως επίσης και την 

χρήση μεγάλων περιοχών στο σκηνικό.. 

Εάν πρέπει να χρησιμοποιήσετε εικόνες bitmap στην ταινία σας, ακολουθήστε τους 

παρακάτω κανόνες: 

 Χρησιμοποιείστε εικόνες bitmap με φειδώ. 

 Αποφύγετε να δώσετε κίνηση σε εικόνες bitmap. 

 Στην διαδικασία κίνησης, μετατρέψτε την εικόνα σε σύμβολο. 
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Χρησιμοποιείστε την εντολή  Trace Bitmap 

Η εντολή Trace Bitmap, που την επιλέγετε από το μενού Modify > Bitmap > Trace Bitmap, 

μετατρέπει μια εικόνα bitmap σε εικόνα ανυσματικών γραφικών, vector. Η τεχνική αυτή 

λειτουργεί καλύτερα σε εικόνες που περιέχουν μεγάλες περιοχές χρώματος. 

 Σε περίπτωση που η εικόνα περιέχει σύνθετες χρωματικές περιοχές και πολλά χρώματα, το 

παραγόμενο γραφικό μπορεί να είναι μεγαλύτερο σε μέγεθος από την αρχική του μορφή. 

Δοκιμάστε τις ρυθμίσεις στο πλαίσιο διαλόγου Trace Bitmap για να βρείτε την ισορροπία 

ανάμεσα στο μέγεθος του αρχείου και την ποιότητα της εικόνας. 

 

Επιλογές συμπίεσης 

Η συμπίεση βοηθάει στην μείωση του 
μεγέθους του αρχείου το οποίο περιέχει 
εικόνες bitmap. Η εξ’ ορισμού συμπίεση για 
όλες τις bitmap εικόνες είναι η JPEG. Στο 
πλαίσιο διαλόγου Publish Settings από το 
μενού File και στην καρτέλα Flash, μπορείτε 
να ρυθμίσετε την τιμή στο πεδίο JPEG 
Quality από 1 (περισσότερη συμπίεση, 
μικρότερη ποιότητα) σε 100 (ελάχιστη 
συμπίεση, μεγαλύτερη ποιότητα) (Εικόνα 1).  
 
Η διαδικασία της συμπίεσης οδηγεί σε 
απώλεια των δεδομένων της εικόνας. Για 
τον λόγο αυτόν, δοκιμάστε την συμπίεση 
των εικόνων σας με διαφορετικές ρυθμίσεις 
έτσι ώστε να πετύχετε την βέλτιστη 
ισορροπία ανάμεσα στην συμπίεση και την 
ποιότητα της εικόνας. 

Εικόνα 1 
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Βελτιστοποιώ ντας τον Ήχο 

Η ύπαρξη του ήχου είναι ένας ακόμα  παράγοντας ο οποίος επηρεάζει το μέγεθος του 

παραγόμενου αρχείου. Με τους παρακάτω τρόπους μπορείτε να πετύχετε την σωστή χρήση 

του ήχου στην ταινία σας και να την κρατήσετε σε ένα επιθυμητό μέγεθος. 

 Χρησιμοποιήστε συμπίεση MP3 η οποία είναι η μικρότερη μορφή ήχου. 

 Διατηρήστε τους ήχους μικρούς σε διάρκεια. 

 Χρησιμοποιήστε το χαμηλότερο bit-rate και την χαμηλότερη αναλογία δείγματος 

για να πετύχετε το μικρότερο μέγεθος δεδομένων. Προσπαθήστε να βρείτε την 

κατάλληλη αναλογία ανάμεσα στην ποιότητα και το μέγεθος. Αυτές οι ρυθμίσεις 

υπάρχουν στο πλαίσιο διαλόγου Sound Settings το οποίο εμφανίζεται όταν 

κάνουμε κλικ στο κουμπί Set στην καρτέλα Flash του πλαισίου διαλόγου Publish 

Settings (εικόνα 2). 

 

 Όταν επαναλαμβάνετε έναν ήχο, χρησιμοποιήστε μικρούς σε μέγεθος ήχους ως 

μουσική υπόβαθρου. 

 Στην διαδικασία της επανάληψης, η χρήση μικρών σε διάρκεια ήχων πετυχαίνει την 

καλύτερη αναπαραγωγή της ταινίας επειδή ο ήχος κατεβαίνει μια φορά και 

χρησιμοποιείτε από εκεί και έπειτα συνέχεια. 

 Μην επαναλαμβάνετε ήχους μεγάλης διάρκειας. 

 Χρησιμοποιήστε την επιλογή Event Sync με την οποία ο ήχος παράγεται όσο 

χρειάζεται στην αναπαραγωγή της ταινίας. Χρησιμοποιήστε την επιλογή Stream 

Sync με την οποία ο ήχος συγχρονίζεται με την αναπαραγωγή της ταινίας. Αν και η 

ρύθμιση stream σημαίνει απώλεια στην ποιότητα του ήχου, δημιουργεί μικρότερα 

σε μέγεθος αρχεία SWF και συγχρονίζει τον ήχο με την κίνηση των αντικειμένων 

στην ταινία.  Οι επιλογές αυτές εμφανίζονται στην περιοχή Sound και στο μενού 

Effect του Properties Inspector. 

 Δοκιμάστε και τους δύο τρόπους, παρακολουθήστε στην αναφορά της ταινίας πως 

κατανέμεται ο ήχος ανάμεσα στα καρέ και χρησιμοποιήστε τις τεχνικές preloading 

προκειμένου να μοιράσετε την ποσότητα των δεδομένων που απαιτούνται ανά 

καρέ ή ανά δευτερόλεπτο.  
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Έλεγχος της ταινίας Flash 

 

Εφόσον μιλάμε για ταινία η οποία θα δημοσιευτεί στο internet, πρέπει να μας ενδιαφέρει 

το μέγεθος της. Όσο μεγαλύτερο είναι το μέγεθος της, τόσο περισσότερο χρόνο θα 

χρειαστεί για να κατέβει - download time. 

Ο έλεγχος για τον χρόνο καταφόρτωσες της ταινίας γίνεται με το Bandwidth profiler. Το 

bandwidth profiler παρέχει πληροφορίες όπως το συνολικό μέγεθος του αρχείου, το 

συνολικό αριθμό καρέ, τις διαστάσεις του stage και την κατανομή των δεδομένων στα καρέ 

Για να εμφανίσουμε το bandwidth profiler, 
επιλέγουμε από το μενού Control > Test 
Movie και από το μενού του flash player 
επιλέγουμε View > Bandwidth profiler. 
 
Εμφανίζεται ένα νέο παράθυρο πάνω από 
την ταινία (Εικόνα 1).  Στην αριστερή πλευρά 
παρατίθενται βασικές πληροφορίες.  Στην 
δεξιά πλευρά εμφανίζεται μια λωρίδα 
χρόνου με γκρι γραμμές που αναπαριστούν 
την ποσότητα δεδομένων σε κάθε καρέ. Όσο 
υψηλότερες είναι οι γραμμές, τόσο 
περισσότερα δεδομένα περιλαμβάνονται. 
 
Το διάγραμμα αυτό εμφανίζεται με δύο 
τρόπους οι οποίοι επιλέγονται από το μενού 
View (Εικόνα 2): 

1. Streaming Graph: Δείχνει πως 
μεταφέρεται η ταινία μέσω του 
Web, παρουσιάζοντας τη ροή 
των δεδομένων από κάθε καρέ. 
Εδώ, φαίνεται ποια καρέ 
προκαλούν «κρέμασμα» κατά 
την αναπαραγωγή 
παρατηρώντας ποια γραμμή 
υπερβαίνει τη δεδομένη 
ρύθμιση Bandwidth.. 

2. Frame by frame: Δείχνει την 
ποσότητα δεδομένων σε κάθε 
καρέ. 

Εικόνα 1 

 
 
Εικόνα 2 

 

 

Μπορούμε να κάνουμε δοκιμή λήψης της ταινίας ως εξής: 

1. Από το μενού View > Download Settings επιλέγουμε την επιθυμητή ταχύτητα. 

Ανάλογα με την επιλογή, στην αριστερή πλευρά και στην περιοχή movie 

παρατηρούμε την ένδειξη preload η οποία αλλάζει ανάλογα με την επιλογή. Επίσης 

παρατηρήστε και την κατανομή των καρέ.  

2. Από το μενού View > Simulate Download γίνεται προσομοίωση της καταφόρτωσης 

της ταινίας.  
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Προσθήκη μεταδεδομένων 

 

Τα μεταδεδομένα, meta data, είναι πληροφορίες οι οποίες περιγράφουν το flash αρχείο 

σας έτσι ώστε άλλοι προγραμματιστές με τους οποίους μοιράζεστε το fla αρχείο σας να 

μπορούν να δουν λεπτομέρειες που θέλετε να γνωρίζουν. Επιπλέον, τα μεταδεδομένα 

χρησιμοποιούνται και από τις μηχανές αναζήτησης κάνοντας διευκολύνοντας με τον τρόπο 

αυτόν την εύρεση του αρχείου σας στο web. 

Τα μεταδεδομένα περιλαμβάνουν: 

 Τον τίτλο, 

 Την περιγραφή, 

 Λέξεις κλειδιά 

 Την ημερομηνία δημιουργίας του εγγράφου και άλλα 

 

1. Επιλέξτε μενού File > Publish 
Settings και μεταβείτε στην 
καρτέλα Flash. 

2. Στην περιοχή SWF Settings 
μαρκάρετε την επιλογή 
Include XMP Metadata και 
κάντε κλικ στο κουμπί File 
Info. 

3. Ανοίγει το παράθυρο 
διαλόγου XMP Metadata 
(εικόνα 1) 

4. Μεταβείτε στην καρτέλα 
Description.  

 
Παρατηρήστε ότι υπάρχουν πεδία με 
αρκετές πληροφορίες τις οποίες 
μπορείτε εδώ να συμπληρώσετε. Οι 
πληροφορίες για τις μηχανές 
αναζήτησης είναι η περιγραφή, 
description, και οι λέξεις-κλειδιά, 
keywords. 

εικόνα 1 
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Εξαγωγή 

 

Μέχρι τώρα, αναπτύσσετε περιεχόμενο με το Flash, χρησιμοποιώντας ένα αρχείο με 

κατάληξη .fla. Το αρχείο αυτό μπορείτε να το ανοίξετε και να το επεξεργαστείτε με το Flash. 

Η ταινία που βλέπουν οι χρήστες σας, είναι δημοσιευμένη σε μια μορφή η οποία είναι 

προσβάσιμη από άλλα λογισμικά. Για τον προσδιορισμό των λογισμικών αυτών, 

χρησιμοποιείτε το πλαίσιο διαλόγου Publish Settings από το μενού File. 

Οι μορφές μιας δημοσιευμένης ταινίας Flash είναι οι ακόλουθες: 

 SWF: Χρησιμοποιείστε αυτήν την μορφή όταν γνωρίζετε πως οι χρήστες σας έχουν 

εγκατεστημένο το Flash Player στον υπολογιστή τους. Αυτή είναι η εξ’ ορισμού 

μορφή ταινιών Flash που δημοσιεύονται στο Web. 

 HTML: Χρησιμοποιείστε την μορφή αυτήν σε συνδυασμό με το αρχείο SWF σε έναν 

φυλλομετρητή ο οποίος έχει εγκατεστημένο το Flash Player. Η μορφή HTML 

χρειάζεται έτσι ώστε οι φυλλομετρητές να μπορούν να ανοίξουν την σελίδα αυτή. 

Στο πλαίσιο διαλόγου Publish Settings είναι επιλεγμένη εξ’ ορισμού και αυτή η 

μορφή. 

 EXE & APP: Χρησιμοποιείστε την μορφή αυτήν όταν γνωρίζετε πως οι επισκέπτες 

σας δεν έχουν εγκατεστημένο το Flash Player στον υπολογιστή τους. Η μορφή EXE 

είναι για τα Windows και η μορφή APP για Macintosh.  

 GIF, JPG & PNG: Χρησιμοποιείστε τις μορφές αυτές για να εξάγετε την ταινία ως 

στατική εικόνα, ως screen shots για υπόδειξη των εικόνων της ταινίας σε κάποιον 

ενδεχόμενο πελάτη. Η επιλογή GIF δίνει την δυνατότητα εξαγωγής κινούμενης 

εικόνας, μη διαδραστικής – animated gif. 

 

 

 

Εξα γοντας το περιεχο μενο Flash ώς εικο να 

Ορισμένες φορές χρειάζεται να εξάγετε το περιεχόμενο μιας ταινίας flash ως εικόνα 

προκειμένου να χρησιμοποιηθεί σε άλλο έγγραφο. Μπορείτε να εξάγετε μια ταινία flash σε 

μορφή JPEG, PNG ή GIF.  Η ενέργεια αυτή είναι παρόμοια με εκείνη της εξαγωγής εικόνων 

στο Adobe Fireworks.  

Όταν επιλέγετε κάποιες από τις μορφές αυτές, το flash προσθέτει τις ανάλογες καρτέλες 

στο πλαίσιο διαλόγου Publish Settings κάθε μία από τις οποίες περιέχει σχετικές ρυθμίσεις 

τις οποίες μπορείτε να τροποποιήσετε. Για παράδειγμα, εάν επιλέξετε την μορφή JPEG, το 

flash προσθέτει μια καρτέλα στην οποία μπορείτε να αλλάξετε τις ρυθμίσεις συμπίεσης για 

το εξαγόμενο αρχείο JPEG. 
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Πώ ς να δημοσιεύ σετε περιεχο μενο Flash 

1. Επιλέξτε Flash > Publish Settings. 

Ανοίγει το πλαίσιο διαλόγου Publish 

Settings με επιλεγμένη την καρτέλα 

Formats (Εικόνα 1). 

2. Επιλέξτε τους τύπους των αρχείων 

στους οποίους θέλετε να 

δημοσιευτεί η ταινία σας. 

3. Εάν επιθυμείτε να αλλάξετε το 

όνομα οποιουδήποτε αρχείου, 

εισάγετε ένα νέο όνομα κάτω από 

το File του αντίστοιχου τύπου. 

Η εξ’ ορισμού ονομασία κάθε τύπου 

αρχείου είναι ίδια με το όνομα του 

.fla αρχείου. Τα μόνα στοιχεία που 

αλλάζουν στο όνομα είναι οι 

επεκτάσεις των αρχείων. 

4. Κάντε κλικ στο εικονίδιο του 

καταλόγου στα δεξιά του ονόματος 

του αρχείου σε περίπτωση που 

θέλετε να αποθηκεύσετε το αρχείο 

σε διαφορετική τοποθεσία. 

Η εξ’ ορισμού τοποθεσία όλων των 

αρχείων είναι ίδια με το .fla αρχείο. 

 

Figure 1 Publish settings 
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5. Επιλέξτε την καρτέλα Flash. 

Ανοίγει η καρτέλα Flash του 

πλαισίου διαλόγου Publish Settings 

(Εικόνα 2). 

6. Για να αλλάξετε την έκδοση Flash η 

οποία υποστηρίζεται από το 

περιεχόμενο της ταινία σας, 

χρησιμοποιείστε το αναδυόμενο 

παράθυρο Player. 

Η εξ’  ορισμού έκδοση του Flash 

είναι η 10. Εάν υπάρχει το 

ενδεχόμενο οι χρήστες σας να 

χρησιμοποιήσουν παλαιότερη 

έκδοση, επιλέξτε την από το μενού. 

7. Για να ελέγξετε τον βαθμό 

συμπίεσης μιας εικόνας bitmap, 

ρυθμίστε τον slider JPEG Quality ή 

εισάγετε μια τιμή. Για περισσότερα, 

δείτε την ενότητα Επιλογές 

συμπίεσης. 

8. θέστε τον ρυθμό δειγματοληψίας 

(sample rate) και την συμπίεση για 

όλους τους ήχους στο παραγόμενο 

αρχείο SWF. Για περισσότερα, δείτε 

την ενότητα Βελτιστοποιώντας τον 

Ήχο. 

9. Κάντε κλικ στην καρτέλα HTML 

(εικόνα 3) 

10. Μαρκάρετε την επιλογή Detect 

Flash Version έτσι ώστε να γίνεται 

έλεγχος της έκδοσης Flash και σε 

περίπτωση απουσίας, να γίνεται 

προτροπή στον χρήστη να την 

κατεβάσει και να την εγκαταστήσει 

προκειμένου να μπορεί να παίξει η 

ταινία στον φυλλομετρητή του 

χρήστη. 

11. Στην επιλογή Dimensions ορίστε το 

μέγεθος της ταινίας σε 

 

Εικόνα 2 Η Καρτέλα Flash 

 

 

Εικόνα 3 Η καρτέλα HTML 
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  πραγματικό μέγεθος,  

 σε μέγεθος σε pixels 

ορίζοντας έτσι διαφορετικές 

διαστάσεις, 

  σε ποσοστό επί τοις εκατό. 

12. Στις επιλογές Playback, ορίζετε εάν  

 θα επαναλαμβάνεται η 

ταινία,  

 θα εμφανίζεται ένα μενού 

με επιλογές όταν ο χρήστης 

θα κάνει δεξί κλικ 

 θα σταματάει η ταινία όταν 

φορτώνει 

13. Πατήστε Publish (στο κάτω μέρος 

του πλαισίου διαλόγου). 

Η ταινία εξάγεται σε κάθε μία από 

τις μορφές που επιλέξατε. 

 Για να δημοσιεύσετε την ταινία σας 

χωρίς να τροποποιήσετε τις 

ρυθμίσεις, επιλέξτε από το μενού 

File > Publish. 

Σημείωση: 

Όταν το Flash δημοσιεύει ένα αρχείο .swf 

και ένα .html, προσθέτει και ένα αρχείο που 

ονομάζεται swfobject.js το οποίο θα 

εντοπίζει την έκδοση του Flash Player που 

καθορίσατε. Εάν το πρόγραμμα περιήγησης 

δεν διαθέτει την παλαιότερη έκδοση Flash 

Player που εισαγάγατε στα πεδία version, θα 

εμφανιστεί ένα μήνυμα αντί για την ταινία 

Flash. 

Τα τρία αυτά στοιχεία είναι απαραίτητα για 

την ταινία σας και συνεπώς πρέπει να 

αποσταλούν στο διακομιστή web 

προκειμένου να λειτουργήσει σωστά το 

flash site σας.  

 


