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7.Κίνηση (animation) 

Εισαγωγή στην κίνηση 

Περίληψη σχετικά με τα ενδιάμεσα καρέ κίνησης 

Η κίνηση, animation, είναι η μεταφορά ή η αλλαγή ενός ή περισσοτέρων αντικειμένων σε σχέση με 

τον χρόνο. Η κίνηση μπορεί να είναι απλή, όπως η μεταφορά από το ένα σκηνικό στο άλλο, ή 

πολύπλοκη.  

Η κίνηση μπορεί να περιλαμβάνει και την αλλαγή των 
χαρακτηριστικών ενός αντικειμένου όπως: 

1. Την φωτεινότητα 
2. Το χρώμα 
3. Την διαφάνεια 
4. Την περιστροφή 
5. Το μέγεθος  

 
 

Το Flash  παρέχει δύο τρόπους δημιουργίας κίνησης:  

 ενδιάμεσα καρέ κίνησης (tweened animation) και  

 κίνηση καρέ-καρέ (frame-by-frame animation).  

Η κίνηση καρέ-καρέ (frame-by-frame animation) περιλαμβάνει μια σειρά από καρέ με διαφορετικό 

σχέδιο σε κάθε καρέ. Αν και αυτό μπορεί να φανεί χρήσιμο σε κάποιες περιπτώσεις, ο ποιο 

συνηθισμένος τρόπος είναι η δημιουργία κίνησης με ενδιάμεσα καρέ κίνησης – tween animation.  

Με την τεχνική αυτήν, σχεδιάζετε κάτι στο πρώτο καρέ από όπου ξεκινάει η κίνηση και στο τελευταίο 

καρέ στο οποίο η κίνηση τερματίζεται. Τα καρέ αυτά, είναι πάντα καρέ κλειδιά, key frames. Έπειτα 

δημιουργείτε animation (tween) ανάμεσα σε αυτά τα καρέ και το Flash γεμίζει αυτόματα τα 

ενδιάμεσα καρέ. Ο όρος tween προέρχεται από την ονομασία των ενδιάμεσων καρέ, in between, τα 

οποία παρεμβάλλονται ανάμεσα στο αρχικό και το τελικό καρέ. Τα ενδιάμεσα καρέ είναι απλά 

frames. 

 Υπάρχουν τρείς τύποι tweened animation στο Flash:  

 animation με βάση την κίνηση (motion tween), 

 animation με βάση το σχήμα (shape tween). 

 κλασικό animation με βάση την κίνηση (classic tween) 
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Animation καρέ-καρέ 

Στην κίνηση καρέ-καρέ, frame by frame animation, μεταβάλουμε ένα σχήμα σε συνεχόμενα 

καρέ κλειδιά. Το σχήμα μπορεί να είναι: 

 ένα γραφικό, οπότε μπορούμε να μεταβάλουμε τις ιδιότητες εμφάνισης του αλλά 

και το σχήμα του, 

 ένα σύμβολο, οπότε μπορούμε να μεταβάλουμε τις ιδιότητες εμφάνισης του αλλά 

όχι και το σχήμα του. 

Σχεδιάζουμε ένα σχήμα σε ένα καρέ κλειδί. Στην συνέχεια προσθέτουμε το επόμενο καρέ 

κλειδί και κάνουμε μια αλλαγή στο σχήμα ή το αντικείμενο. Συνεχίζουμε την διαδικασία 

αυτή, προσθήκη καρέ και αλλαγή, όσο θέλουμε. Σε αυτόν τον τύπο κίνησης μπορούμε να 

έχουμε όσα αντικείμενα θέλουμε σε ένα επίπεδο. 

Για να προσθέσω ένα καρέ κλειδί κάνω κλικ στο σημείο που θέλω και: 

 κάνω δεξί-κλικ στο σημείο που θέλω, στην λωρίδα χρόνου και επιλέγω insert key 

frame ή 

 επιλέγω από το μενού Insert > Timeline > Key frame ή 

 πατάω στο πληκτρολόγιο το F6. 

Το πλεονέκτημα είναι ότι μεταβάλουμε το αντικείμενο ακριβώς όπως επιθυμούμε. Το 

μειονέκτημα είναι ότι είναι αρκετά χρονοβόρο. 
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Η λειτουργία Onion Skin 

Όταν μετακινούμε την κεφαλή αναπαραγωγής καρέ προς καρέ βλέπουμε την τρέχουσα 

κατάσταση του σχήματος. Μπορούμε να βλέπουμε παράλληλα τις προηγούμενες και 

τις επόμενες , από την τρέχουσα, καταστάσεις  του σχήματος . Η τεχνική αυτή 

ονομάζεται Onion Skin και οι επιλογές, οι οποίες βρίσκονται στο κάτω μέρος της 

λωρίδας χρόνου είναι: 

 Onion Skin: Ενεργοποιώντας την επιλογή αυτή, εμφανίζονται εκατέρωθεν της 

κεφαλής αναπαραγωγής λαβές, markers, οι οποίοι καλύπτουν ένα εύρος το 

οποίο επισημαίνεται με χρώμα γκρι. Με τον τρόπο αυτόν βλέπουμε το εύρος 

που καλύπτει η κίνηση.  Μπορούμε να μετακινήσουμε τους λαβές 

αυξομειώνοντας ανάλογα το εύρος. 

Το σχήμα στο τρέχων καρέ το βλέπουμε κανονικά, ενώ τα σχήματα στα 

υπόλοιπα καρέ εμφανίζονται με αχνό χρώμα. Μπορούμε να επεξεργαστούμε 

μόνο το σχήμα στο τρέχων καρέ. 

 Onion Skin Outlines: Η επιλογή αυτή μοιάζει με την προηγούμενη, με την 

διαφορά ότι τα υπόλοιπα σχήματα εμφανίζονται ως περιγράμματα.  

 Edit Multiple Frames: Ενεργοποιώντας την επιλογή αυτή, τα σχήματα στα 

υπόλοιπα καρέ εμφανίζονται με κανονικό χρώμα και επιπλέον μπορούμε να τα 

επεξεργαστούμε σε όλο το εύρος του onion skin. 

 Modify Onion Markers: Εμφανίζει ένα μενού με επιλογές για την εμφάνιση των 

δεικτών. 

 

Σημείωση:  

 Κάθε φορά μπορεί να είναι ενεργή μόνο το onion skin ή το onion skin outlines. 

Η επιλογή edit multiple frames μπορεί να είναι ενεργή ανεξάρτητα από τις 

προηγούμενες δύο επιλογές. 

 Μπορούμε να κινηθούμε προς πίσω στην ταινία είτε μετακινώντας την κεφαλή 

αναπαραγωγής, είτε με τα πλήκτρα < και > του πληκτρολογίου.  
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Animation με βάση την κίνηση – Motion tween 

Στο motion tween: 
1. Τοποθετούμε ένα σύμβολο σε ένα 

καρέ κλειδί π.χ. στο 1. 
2. Κάνουμε δεξί-κλικ στο καρέ κλειδί 

και επιλέγουμε create motion 
tween.  

a. Το επίπεδο αλλάζει 
εικονίδιο  

b. το flash βάζει ορισμένα καρέ 
τα οποία έπονται του καρέ 
κλειδιού και τα οποία 
εμφανίζονται με μπλε 
χρώμα. Μπορούμε να 
μεταβάλουμε το μήκος του 
animation μεταβάλλοντας 
την δεξιά πλευρά του. 

c. Η κεφαλή αναπαραγωγής 
βρίσκεται στο τελευταίο 
καρέ. 

3. Τοποθετούμε την κεφαλή 
αναπαραγωγής στην θέση που 
επιθυμούμε και κάνουμε τις 
αλλαγές που θέλουμε στο σύμβολο.  
Με την εφαρμογή των αλλαγών το 
Flash τοποθετεί μια μικρότερη 
τελεία στο τρέχων καρέ η οποία 
ονομάζεται pose και η οποία 
δηλώνει αλλαγή στο συγκεκριμένο 
καρέ. 
 
Επιπλέον, εμφανίζεται στο σκηνικό 
μια πράσινη γραμμή η οποία ορίζει 
το ευθύγραμμο μονοπάτι της 
μεταβολής του σχήματος στον χώρο. 
Την γραμμή αυτήν μπορούμε να την 
μεταβάλουμε: 

a. Με το εργαλείο selection, 
π.χ. μετατρέποντας την ως 
καμπύλη 

b. Με το εργαλείο covert 
anchor point, π.χ. 
καμπύλωση πολλών 
σημείων. 

 

 Μπορώ να ορίσω όσα poses 
επιθυμώ.  

 Μπορώ να μεταβάλω τις  ιδιότητες, 
Style, της περιοχής Color Effect, της 
παλέτας Properties. 
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Περιορισμοί στο motion tween 

 Αυτόν τον τύπο κίνησης μπορώ να τον εφαρμόσω μόνο σε σύμβολα. 

 Σε κάθε επίπεδο πρέπει να υπάρχει μόνο ένα σύμβολο 
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Animation με βάση το σχήμα – Shape tween 

Στο Flash, ένα σχήμα είναι ένα ανυσματικό αντικείμενο ή μια σειρά από αντικείμενα σχεδιασμένα 

με τα εργαλεία σχεδίασης. Ένα tween σχήματος δημιουργεί ομαλές μεταβάσεις μεταξύ key frames 

που περιέχουν διαφορετικά σχήματα. Για να πετύχετε animation με βάση το σχήμα, το αντικείμενο 

δεν πρέπει να είναι σύμβολο, εικόνα ή ομαδοποιημένο αντικείμενο. Για να εφαρμόσετε animationμε 

βάση το σχήμα σε κείμενο, πρέπει πρώτα να μετατρέψετε το κείμενο σε σχήμα σπάζοντας το – break 

apart. 

Ένα παράδειγμα χρήσης της τεχνικής αυτής είναι η μετατροπή της λέξης ‘ελέφαντας’ σε εικόνα 

ελέφαντα. 

Το animationμε βάση το σχήμα χρησιμοποιείται για: 

 Αλλαγή του σχήματος ενός αντικειμένου (μορφοποίηση από ένα σχήμα σε ένα άλλο) 

 Αλλαγή του χρώματος ενός αντικειμένου (συμπεριλαμβανομένου του εφέ διαφάνειας) 

 Αλλαγή της θέσης ενός αντικειμένου (μοιάζει με το animation βασισμένο στη κίνηση αλλά 
μεταξύ σχημάτων και όχι συμβόλων) 

 Αλλαγή ενός κειμένου το οποίο έχει διασπαστεί σε σχήμα (break apart) 

 Αλλαγή μιας εικόνας bitmap η οποία έχει διασπαστεί σε σχήμα (break apart) 

Δεν μπορείτε να χρησιμοποιήσετε animation βασισμένο στο σχήμα σε: 

 Ομαδοποιημένα αντικείμενα 

 Σύμβολα 

 Κείμενο το οποίο δεν έχει μετατραπεί σε σχήμα 

 Εικόνα η οποία δεν έχει μετατραπεί σε σχήμα 
 

Σημείωση: Η τεχνική αυτή χρησιμοποιεί περισσότερη μνήμη από το βασισμένο στην κίνηση 

animation, οπότε είναι προτιμότερο να την χρησιμοποιείτε με φειδώ. Επίσης, συνίσταται η χρήση 

απλών σχημάτων. 

Μπορείτε να χρησιμοποιήσετε περισσότερα από ένα σχήματα στο ίδιο επίπεδο αλλά υπάρχει ο 

κίνδυνος να αναμειχθούν μεταξύ τους κατά την διάρκεια της κίνησης. 

Με την τεχνική αυτήν, μπορείτε να αλλάξετε τις ακόλουθες ιδιότητες: 

 Color (tint) 

 Alpha (Διαφάνεια) 

 Shape 
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Παράδειγμα για shape tween 

Για να αλλάξετε το χρώμα ή την διαφάνεια ενός σχήματος, χρησιμοποιήστε την παλέτα Color. 

1. Ξεκινήστε το Flash και ανοίξτε ένα νέο κενό έγγραφο. 

Το καρέ 1 του επιπέδου (Layer) 1 περιέχει είδη ένα κενό καρέ κλειδί. 

2. Ξεκινήστε εισάγοντας ένα κενό σχήμα στο σκηνικό: 

 Σχεδίαση αντικειμένων: Επιλέξτε ένα εργαλείο σχεδίασης (rectangle ή oval) και σχεδιάστε 
στην σκηνή ένα αντικείμενο. 

 Κείμενο: Επιλέξτε το εργαλείο κειμένου (text) και γράψτε στην σκηνή μια λέξη ή φράση. 
Έπειτα επιλέξτε το κείμενο και από το μενού επιλέξτε Modify > Break Apart. Η ενέργεια 
αυτή σπάει την λέξη σε γράμματα. Με τα γράμματα επιλεγμένα επιλέξτε πάλι από το μενού 
Modify > Break Apart για να μετατρέψετε τα γράμματα σε σχήματα. 

 Εξωτερικές εικόνες: Επιλέξτε File > Import για να εισάγετε μια εικόνα. Εάν η εικόνα είναι 
bitmap, πρέπει να την κάνετε break apart. Εάν είναι ομάδα από ανυσματικά σχήματα, 
πρέπει να την κάνετε πλήρως break apart.  Για να το κάνετε αυτό σε εικόνα bitmap επιλέξτε 
Modify > Break Apart. Εάν είναι ομάδα σχημάτων, επιλέξτε Modify > Ungroup. 

 Σημείωση: Ίσως χρειαστεί να εκτελέσετε πολλές φορές την εντολή Modify > Break Apart ή 
Modify > Ungroup σε ένα αντικείμενο μέχρι να γίνει σχήμα (αυτό φαίνετε στον επιθεωρητή 
ιδιοτήτων). 

3. Επιλέξτε το καρέ 10. 

4. Επιλέξτε Insert > Timeline > Key frame. Με τον τρόπο αυτό το tween θα κρατήσει 10 καρέ. 

5. Βεβαιωθείτε ότι έχετε επιλεγμένο το καρέ 10 και κάντε μία ή όλες από τις ακόλουθες ενέργειες: 

Άμορφη αλλαγή σχήματος: Με το εργαλείο Select, κάντε κλικ στο σκηνικό για να από επιλέξετε το 

σχήμα. Φέρτε το εργαλείο Selection κοντά στο σχήμα και όταν δίπλα στον δείκτη του ποντικιού 

εμφανιστεί μια καμπύλη ή μια οξεία γωνία, σύρετε για να αλλάξετε το σχήμα του αντικειμένου 

(Εικόνα 1). 

Εικόνα 1- Αλλαγή του σχήματος με το εργαλείο Selection 

 

 Διαφοροποίηση σχήματος: Για να μορφοποιήσετε το σχήμα σας από το αρχικό σε ένα 
καινούργιο, διαγράψτε το σχήμα στο καρέ 10 και σχεδιάστε ένα νέο αντικείμενο. Σημείωση: 
Εάν το σχήμα δεν είναι σχέδιο, επιλέξτε Modify > Break Apart. 

 Κείμενο: Για να μορφοποιήσετε το αρχικό σχήμα σε κείμενο, διαγράψτε το σχήμα στο καρέ 
10 και γράψτε στο σκηνικό ένα κείμενο. Επιλέξτε Modify > Break Apart μέχρι το μπλοκ 
κειμένου να γίνει σχήμα (αυτό φαίνετε στον επιθεωρητή ιδιοτήτων). 

 Εξωτερική εικόνα: Για να μορφοποιήσετε το αρχικό σχήμα σε εικόνα, διαγράψτε το σχήμα 
στο καρέ 10 και επιλέξτε File > Import για να φέρετε μια άλλη εικόνα στο σκηνικό. Εάν 
χρειάζεται, επιλέξτε Modify > Break Apart για να μετατρέψετε την εικόνα σε σχήμα. 

6. Επιλέξτε, στο τρέχων επίπεδο και στην λωρίδα χρόνου, το καρέ 1. 

Αυτό είναι το καρέ έναρξης του animation. 



9 
 

Κάντε δεξί-κλικ στο καρέ έναρξης και επιλέξτε Create Shape Tween (Εικόνα 2). 

 

Εικόνα 2 Ο επιθεωρητής ιδιοτήτων για το tween 

7. Ρυθμίστε μια ή περισσότερες από τις ακόλουθες ιδιότητες για το shape tween: 

 Ease: Ελέγχει την ταχύτητα του shape tween. Όσο μεγαλύτερος είναι ο αριθμός τόσο 
γρηγορότερα ξεκινάει το animation και τερματίζει με μικρότερη ταχύτητα. 

 Blend (Distributive): Δημιουργεί ένα animation στο οποίο τα ενδιάμεσα σχήματα έχουν 
εξομαλυμένες άκρες και είναι λιγότερο φυσικά. 

 Blend (Angular): Δημιουργεί ένα animation στο οποίο τα ενδιάμεσα σχήματα έχουν 
διατηρήσει τις γωνίες και τις ευθείες γραμμές. 

8. Επιλέξτε Control > Test movie για να δοκιμάσετε την ταινία σας. 

9. Επιλέξτε File > Close για να κλείσετε το παράθυρο προεπισκόπησης. 

10. Για να δείτε όλες τις φάσεις του tween την ίδια χρονική στιγμή, κάντε κλικ στο κουμπί Onion 
Skin Outline στο κάτω μέρος της λωρίδας χρόνου. 

11. Σύρετε τις λαβές του onion skinning (εμφανίζονται σαν άγκιστρα με κύκλους στο πάνω μέρος 
της λωρίδας χρόνου) για να δείτε τα πρώτα 10 καρέ στο επίπεδο 1. 

Η πρόοδος του animation εμφανίζεται πλήρως στην σκηνή. 

12. Κλείστε το onion skinning. 

13. Αποθηκεύστε και κλείστε την ταινία. 
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Δίνοντας κίνηση στην μάσκα 

Συνέχεια από την ενότητα 5 > Η ιδιότητα της μάσκας στα επίπεδα. 

Μπορείτε να μετακινείτε την μάσκα έτσι ώστε, για παράδειγμα, να κινείται επάνω στην εικόνα. 

1. Στο επίπεδο mask, προσθέστε ένα καρέ κλειδί στο καρέ 20. 

2. Στο ακριβώς από κάτω επίπεδο, προσθέστε επίσης ένα καρέ κλειδί στο καρέ 20. 

3. Στο επίπεδο Mask, επιλέξτε το καρέ κλειδί στο καρέ 20 για να διαλέξετε το αντικείμενο. 

4. Κάντε μια αλλαγή στο αντικείμενο της μάσκας. 

5. Στο επίπεδο Mask, κάντε δεξί κλικ σε ένα οποιοδήποτε καρέ ανάμεσα στα καρέ 1 και 20. 

6. Στο μενού επιλέξτε Create shape tween. 

7. Επιλέξτε Control > Test Movie. 

Παρατηρήστε ότι εμφανίζεται μόνο εκείνο το κομμάτι της εικόνας που είναι κάτω από την 

μάσκα καθώς εκείνη κινείται πάνω από την εικόνα. 

8. Επιλέξτε File > Closeγια να κλείσετε το παράθυρο προεπισκόπησης. 

 

Αλλαγή των καλυμμένων από την μάσκα περιεχομένων 

Μπορείτε να τροποποιήσετε τα περιεχόμενα του επιπέδου που βρίσκεται κάτω από την μάσκα 

διατηρώντας την μάσκα ίδια. 

9. Στο επίπεδο που έχετε την εικόνα, κάτω από αυτό της μάσκας, επιλέξτε το καρέ 10 και επιλέξτε 
Insert > Timeline > Blank Key frame. 

Εισάγοντας ένα κενό καρέ κλειδί, διαγράφονται όλα τα περιεχόμενα του τρέχοντος καρέ. 

10. Προσθέστε περιεχόμενο στο καρέ 10. 

Μπορείτε, για παράδειγμα, να προσθέσετε μια άλλη εικόνα στο σκηνικό. 

11. Επιλέξτε Control > Test Movie. 

Παρατηρήστε ότι η εικόνα κάτω από την μάσκα αλλάζει στο μέσω της κίνησης. 

12. Επιλέξτε File > Close για να κλείσετε το παράθυρο προεπισκόπησης. 

Επαναφέροντας το καλυμμένο περιεχόμενο στην αρχική του κατάσταση 

13. Επιλέξτε το τελευταίο καρέ κλειδί που εισάγατε, για παράδειγμα το καρέ 10, και από το μενού 
επιλέξτε Modify > Timeline > Clear Key frame. 

Η ενέργεια αυτή επαναφέρει το τρέχων καρέ στην αρχική του κατάσταση αφού δεν υπάρχει πλέον 

κάποιο ενδιάμεσο καρέ με διαφορετικό περιεχόμενο.  
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Animation με τον κλασικό τρόπο - Classic Tween 

Μπορείτε  να χρησιμοποιήσετε αυτήν την τεχνική για τα ακόλουθα στοιχεία: 

 Ένα σύμβολο (graphic, button ή movie clip) 

 Ένα ομαδοποιημένο αντικείμενο (μια συλλογή από σχήματα τα οποία έχουν ομαδοποιηθεί) 

 Ένα μπλοκ κειμένου 
 

Όταν χρησιμοποιείτε αυτήν την τεχνική για να κινήσετε ένα σύμβολο, μπορείτε να αλλάξετε τις 

ακόλουθες ιδιότητες: 

 Το χρώμα (tint) 

 Alpha (διαφάνεια) 

 Θέση 

 Μέγεθος 
 

Η διαφορά με το Motion Tween είναι ότι η κίνηση του αντικειμένου μπορεί να είναι μόνο γραμμική. 

Για παράδειγμα, μπορείτε να παράγετε animationμε βάση την κίνηση για να δώσετε το εφέ της 

κύλισης ενός κειμένου κατά μήκος του σκηνικού. Εάν θέλετε όμως το κείμενο να εξαφανίζεται αργά 

κατά μήκος της σκηνής, πρέπει πρώτα να το μετατρέψετε σε σύμβολο. Έπειτα χρησιμοποιήστε τις 

ιδιότητες, στον επιθεωρητή ιδιοτήτων, Color και Alpha για να δώσετε το εφέ που θέλετε. 
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Παράδειγμα χρήσης του Classic Tween 

1. Ξεκινήστε το Flash και ανοίξτε ένα νέο έγγραφο. 

2. Σχεδιάστε ένα σχήμα στην σκηνή ή εισάγετε μια εικόνα επιλέγοντας File> Import> Import to 
Stage. 

Παρατηρήστε ότι το σχήμα εμφανίζεται στο πρώτο καρέ του Layer 1. 

3. Εάν σχεδιάσατε το αντικείμενο, επιλέξτε το με το με το εργαλείο Selection κάνοντας διπλό-κλικ 
πάνω του. 

Εάν το έχετε εισάγει, επιλέξτε το με το με το εργαλείο Selection κάνοντας απλά κλικ πάνω του. 

4. ΕπιλέξτεModify > Convert to Symbol. 

Ανοίγει το πλαίσιο διαλόγου Convert to Symbol. 

Σημείωση: Δεν μπορείτε να παράγετε animation βασισμένο στην κίνηση σε σχήματα. Πρέπει 

πρώτα να μετατρέψετε το σχήμα σε σύμβολο. 

5. Δώστε ένα όνομα στο σύμβολο στο πλαίσιο κειμένου name , επιλέξτε Graphic και πατήστε OK. 
 

6. Επιλέξτε το καρέ 10. 

Επιλέξτε Insert > Timeline > Key frame  
(Εικόνα 1).  
 
Εικόνα 1 Τα εισαχθέντα καρέ 
Με τον τρόπο αυτόν η κίνηση θα κρατήσει για 10 καρέ. 

 

Παρατηρήστε ότι όταν εισάγατε το καρέ κλειδί, το Flash γέμισε την περιοχή ανάμεσα στο νέο 

καρέ κλειδί και το τελευταίο καρέ, στο τρέχων επίπεδο, με το ίδιο περιεχόμενο. Τα καρέ 1 μέχρι 

και το 10 περιέχουν το νέο σύμβολο. 

1. Βεβαιωθείτε πως έχετε επιλεγμένο το καρέ 10. Αυτό είναι το τελευταίο καρέ του animation. 
Επιλέξτε το στιγμιότυπο του συμβόλου στο καρέ 10 και έπειτα κάντε ένα από τα παρακάτω: 

 Αλλαγή χρώματος: Στον επιθεωρητή ιδιοτήτων και από το αναδυόμενο μενού Style επιλέξτε 
Tint (Εικόνα 2). 

Εικόνα 2 Το αναδυόμενο μενού Style 
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 Διαφάνεια: Στον επιθεωρητή ιδιοτήτων και από το αναδυόμενο μενού Color επιλέξτε Alpha. 
Μειώστε το ποσοστό διαφάνειας για περισσότερη διαφάνεια. Για παράδειγμα η τιμή 0% 
κάνει το αντικείμενο αόρατο. 

 Θέση: Χρησιμοποιήστε το εργαλείο Selection για να μετακινήσετε το αντικείμενο σε 
διαφορετική θέση. 

 Μέγεθος: Επιλέξτε το αντικείμενο και από το μενού επιλέξτε Modify > Transform > Free 
Transform. Μπορείτε να αλλάξετε το μέγεθος του αντικειμένου σύροντας τις άκρες του και 
να το περιστρέψετε. 

2. Επιλέξτε το καρέ 1 στην λωρίδα χρόνου.  

3. Κάντε δεξί-κλικ στο καρέ κλειδί και επιλέξτε Classic Motion Tween. 

Τα ενδιάμεσα καρέ φαίνονται από ένα μαύρο βέλος σε μπλε υπόβαθρο το οποίο ξεκινάει από 

το αρχικό μέχρι το τελευταίο καρέ κλειδί. 

4. Στον επιθεωρητή ιδιοτήτων (Εικόνα 3), ρυθμίστε κάποιες από τις παρακάτω ιδιότητες: 

Εικόνα 3 Tween Property Inspector 

 

 

 Ease: Ελέγχει την ταχύτητα έναρξης ή τερματισμού του animation. Για παράδειγμα, μεγάλο 
νούμερο σημαίνει γρήγορη έναρξη και αργός τερματισμός. 

 Rotate: Περιστρέφει το αντικείμενο δεξιόστροφα ή αριστερόστροφα κάποιες φορές. 

 Scale: Διατηρεί τις αναλογίες του αντικειμένου. 

 Orient to path: Εάν έχετε προσθέσει ένα επίπεδο-οδηγό, guide layer, το αντικείμενο 
συνδέετε με το αντικείμενο που υπάρχει σε αυτό το επίπεδο. 

 Sync: Συγχρονίζει την έναρξη και τον τερματισμό του animation για όλα τα αντικείμενα που 
βρίσκονται στο σκηνικό. 

 Snap: Διατηρεί τα αντικείμενα ευθυγραμμισμένα με ένα αόρατο πλέγμα ελέγχοντας έτσι της 
απόσταση τους. 

5. Επιλέξτε Control > Test Movie για να ελέγξετε την ταινία σας. 

6. Επιλέξτε File>Closeγια να κλείσετε το παράθυρο προεπισκόπησης. 

7. Για να δείτε όλες τις φάσεις του tween την ίδια χρονική στιγμή, κάντε κλικ στο κουμπί Onion 
Skin Outline στο κάτω μέρος της λωρίδας χρόνου (Εικόνα 4). 

Εικόνα 4 Το κουμπί Onion Skin Outline 
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8. Σύρετε τις λαβές του onion skinning (εμφανίζονται σαν άγκιστρα με κύκλους στο πάνω μέρος 
της λωρίδας χρόνου) για να δείτε τα καρέ στα οποία εμφανίζεται το αντικείμενο. 

Η πρόοδος του animation εμφανίζεται πλήρως στην σκηνή. 

9. Κλείστε το onion skinning. 

10. Αποθηκεύστε την ταινία. 
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Σύγκριση του motion tween και του shape tween 

Ο ακόλουθος πίνακας σας βοηθάει να επιλέξετε τον τύπο του animation ανάλογα με το τύπο των 

αντικειμένων που έχετε. 

 
Σχήμα Ομάδα Σύμβολο 

Μπλοκ 

Κειμένου 

Σπασμένο κείμενο 

(break apart) 

Shape Tween Ναι Όχι Όχι Όχι Ναι 

Motion Tween 

& 

Classic Motion 

Tween 

Όχι Ναι Ναι Ναι Όχι 
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Συχνά προβλήματα και λύσεις για το βασισμένο στην κίνηση animation 

Το tween που δημιουργήσατε προβάλλεται στην λωρίδα χρόνου από  

 ένα μαύρο βέλος σε μπλε υπόβαθρο (classic motion tween) 

 ένα μαύρο βέλος σε πράσινο υπόβαθρο (shape tween) 

 μπλε υπόβαθρο (motion tween) 

 

Εάν το βέλος δεν υπάρχει, τότε εμφανίζεται ως διακεκομμένο. Υπάρχουν διάφοροι τρόποι για να 

διορθώσετε αυτό το πρόβλημα. 

Όσον αφορά το motion tween, διαγράφοντας ένα αντικείμενο, γίνεται άσπρη από μαύρη η κουκίδα 

στο καρέ κλειδί από το οποίο ξεκινάει η κίνηση. Δεν μπορούμε να σχεδιάσουμε κάτι όταν έχει 

εφαρμοστεί η κίνηση, ούτε και να κάνουμε το σχήμα break apart. Εάν δοκιμάσουμε να 

τοποθετήσουμε ένα στιγμιότυπο στο σκηνικό, θα γίνει προτροπή από το Flash να αντικαταστήσει το 

τρέχων. 

Ο παρακάτω πίνακας αφορά το motion και το classic tween 

Πρόβλημα Λύση 

Δεν υπάρχει καρέ κλειδί στην αρχή ή στο τέλος 

του motion tween. 

Αφαιρέστε το motion tween κάνοντας δεξί-κλικ 

και επιλέγοντας remove tween. Έπειτα επιλέξτε 

το αρχικό ή το τελικό καρέ και επιλέξτε Insert > 

Time line > Key frame.  

Τέλος, εισάγετε πάλι το motion tween. 

Τα αντικείμενα στα καρέ κλειδιά δεν είναι ίδια. κάνοντας δεξί-κλικ και επιλέγοντας remove 

tween. Κάντε δεξί-κλικ και επιλέξτε Clear Key 

frame. Σιγουρευτείτε ότι το πρώτο καρέ κλειδί 

περιέχει τα σωστά αντικείμενα. Εισάγετε το 

δεύτερο καρέ κλειδί και προσθέστε ένα motion 

tween. 

Δύο καρέ κλειδιά περιέχουν αντικείμενα τα 

οποία δεν είναι στιγμιότυπα συμβόλων, 

ομαδοποιημένα αντικείμενα ή μπλοκ κειμένου. 

Αφαιρέστε το motion tweenκαι διαγράψτε τα 

περιεχόμενα του δεύτερου καρέ. Εάν είναι 

απαραίτητο, μετατρέψτε τα αντικείμενα που 

βρίσκονται στο πρώτο καρέ κλειδί σε σύμβολα ή 

αφαιρέστε τα από την σκηνή. Προσθέστε το 

δεύτερο καρέ κλειδί και έπειτα το motion tween. 

Υπάρχουν περισσότερα από ένα αντικείμενα σε 

ένα καρέ. Το motion tweening δεν συμβαίνει σε 

επίπεδο με περισσότερα από ένα αντικείμενα ή 

ομάδες αντικειμένων. 

Αφαιρέστε το motion tweenκαι τοποθετήστε 

κάθε αντικείμενο σε ξεχωριστό επίπεδο. Έπειτα 

δημιουργήστε ξεχωριστό motion tween για κάθε 

σύμβολο το οποίο βρίσκεται σε ξεχωριστό 

επίπεδο. 
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Bone Tool 

Περιγραφή 

Με το εργαλείο αυτό φτιάχνουμε και κινούμε ένα αρθρωτό αντικείμενο όπως ένας 

άνθρωπος που περπατά 

Το αρθρωτό αυτό αντικείμενο μπορεί να αποτελείται από  

 Σχήματα τα οποία είναι απλά σχέδια ή  

 αποσπάσματα (στιγμιότυπα) σε μια λογική σειρά τα οποία στην συνέχεια 

συνδέονται με οστά.   

Το σύνολο των συνδεδεμένων αποσπασμάτων ονομάζεται κινηματική αλυσίδα (armature) 

η οποία αποτελείται από: 

1. Έναν κόμβο ο οποίος είναι ένα 
από τα στιγμιότυπα 
αποσπασμάτων ταινίας που 
έχουν συνδεθεί με το εργαλείο 
bone. 

2. Τα οστά τα οποία είναι 
αντικείμενα τα οποία συνδέουν 
μεμονωμένα αποσπάσματα 
ταινίας μεταξύ τους και 
αποτελούν την εσωτερική δομή 
ενός σχήματος για κίνηση με 
αντίστροφή κινηματική (ένας 

μαθηματικός τρόπος υπολογισμού 
των διαφόρων γωνιών ενός 
αρθρωτού αντικειμένου με σκοπό 
την επίτευξη μιας συγκεκριμένης 

διαμόρφωσης). 
3. Οι αρθρώσεις οι οποίες 

αποτελούν τις ενώσεις μεταξύ 
κόμβων και οι οποίες μπορούν 
να περιστραφούν και να 
μετασχηματιστούν. 

Εικόνα 33a 
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Σχεδίαση 

Τοποθετούμε τα στιγμιότυπα, τα οποία θα συνθέσουν το αντικείμενο, σε ένα επίπεδο και: 

1. Κάνουμε κλικ στην βάση του πρώτου 
στιγμιότυπου δηλαδή στο σημείο το 
οποίο ξεκινάει η άρθρωση, σέρνουμε 
μέχρι την βάση του άλλου αντικειμένου 
όπου και αφήνουμε το πλήκτρο του 
ποντικιού. 

2. Κάνουμε κλικ στο προηγούμενο σημείο, 
σέρνουμε μέχρι την βάση του άλλου 
στιγμιότυπου και αφήνουμε το πλήκτρο 
του ποντικιού. 
Επαναλαμβάνουμε την ίδια διαδικασία 
όσες φορές χρειάζεται. 

3. Αφού τελειώσουμε, παρατηρούμε πως το 
επίπεδο του αντικειμένου είναι κενό, 
εφόσον δεν υπάρχουν άλλα αντικείμενα, 
και το σύνολο των συνδεδεμένων 
αντικειμένων εμφανίζονται σε ένα νέο 
επίπεδο με όνομα Armature. 

Εικόνα 33b 
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Ιδιότητες 

Εφόσον τα αντικείμενα είναι συνδεδεμένα, μπορώ να κάνω κλικ με το εργαλείο selection 

οπουδήποτε στο σχήμα οπότε και βλέπω ένα μικρό οστό δίπλα από τον δείκτη του 

ποντικιού και στην συνέχεια: 

 Αν κάνω κλικ σε ένα οστό ή έναν κόμβο μετακινώ τα αντικείμενα του σχήματος 

ανάλογα με το σημείο κρατήματος. 

 Αν έχω κρατημένο το πλήκτρο Shift και κάνω κλικ σε ένα οστό, μετακινώ μόνο τα 

αντικείμενα τα οποία είναι σε κατώτερη σειρά ιεραρχίας από το σημείο 

κρατήματος, ενώ τα υπόλοιπα μένουν ακίνητα. 

Ιδιότητες 
Όταν κάνουμε κλικ σε ένα οστό, 
στην παλέτα properties inspector 
βλέπουμε τις ακόλουθες 
ιδιότητες: 
1. Τα κουμπιά ιεραρχίας, με 

σχέση γονέα-παιδιού, με τα 
οποία μπορούμε να 
μεταβαίνουμε από οστό σε 
οστό. 
Το όνομα του οστού είναι για 
χρήση για action script. 

2. Πληροφορίες για την θέση και 
την ταχύτητα μεταβολής της 
άρθρωσης στην λωρίδα 
χρόνου. 

3. Περιορισμός στην κίνηση 
περιστροφής Για μεγαλύτερη 
απόδοση ρεαλισμού στην 
κίνηση. Ορίζουμε μια 
maximum και minimum 
γωνία περιστροφής.  

4. Περιορισμός της κίνησης 
μετασχηματισμού της 
άρθρωσης οριζοντίως (άξονας 
x). Η άρθρωση μπορεί να 
κινείται οριζοντίως. 

5. Περιορισμός της κίνησης 
μετασχηματισμού της 
άρθρωσης καθέτως (άξονας 
y). Η άρθρωση μπορεί να 
κινείται καθέτως. 

Εικόνα 33c 
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Κίνηση 

Μπορούμε να τοποθετήσουμε ένα αρθρωτό αντικείμενο σε ένα καρέ κλειδί και σε ένα 

άλλο καρέ κλειδί να το τοποθετήσουμε σε μια άλλη πόζα (pose). Στην συνέχεια μπορούμε 

να εφαρμόζουμε tweening προσδίδοντας σε αυτό κίνηση. Η κίνηση αυτή απλοποιείται από 

το Flash με την εφαρμογή της αντίστροφής κινηματικής (inverse kinetics).  

Για να εφαρμόσουμε κίνηση στο αρθρωτό αντικείμενο: 
1. Εισάγουμε ένα καρέ στο χρονικό σημείο που επιθυμούμε να τερματιστεί η κίνηση. 
2. Μεταφέρουμε την κεφαλή αναπαραγωγής στο χρονικό σημείο που επιθυμούμε. 
3. Προκαλούμε μια αλλαγή στο αρθρωτό αντικείμενο. Όταν συμβεί αυτό, εμφανίζεται 

μια κουκίδα pose στο τρέχων καρέ  το οποίο υποδηλώνει μια αλλαγή στο σημείο 
αυτό. 
Εάν θελήσουμε να αφαιρέσουμε ένα pose: 

 Επιλέγουμε το καρέ στο οποίο εμφανίζεται το pose 

 Κάνουμε δεξί κλικ 

 Επιλέγουμε remove pose 
Εικόνα 33d 

 
Ομαλότητα Κίνησης 

Κάνοντας κλικ στο επίπεδο του αρθρωτού αντικειμένου, armature_x, βλέπουμε τις 

ακόλουθες ιδιότητες στον properties inspector: 

Ease: Ορίζουμε την ταχύτητα κίνησης από το τρέχων σημείο, pose, μέχρι το επόμενο 

σημείο. Μπορούμε να ορίσουμε τιμή στο Strength (αρνητική για επιτάχυνση, θετική για 

επιβράδυνση) ή κάποια προεπιλογή στο Type. 

Options: 

 Type: Ορίζει αν η κίνηση θα γίνεται με την αναπαραγωγή της ταινίας (author time) 

ή αν θα την κάνει ο χρήστης (Run time). 

 Style: Ορίζει την εμφάνιση των οστών. 
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Bind Tool 

Ο οργανικός έλεγχος ενός σχήματος από την κινηματική αλυσίδα του είναι το αποτέλεσμα 

μιας αντιστοίχισης μεταξύ των σημείων άγκυρας κατά μήκος του σχήματος και των οστών 

του. Το εργαλείο bind επεξεργάζεται τις συνδέσεις μεταξύ των οστών και των σημείων 

ελέγχου.  Η χρήση του εργαλείου bind εφαρμόζεται μόνο σε σχέδια και όχι σε στιγμιότυπα. 

1. Έχοντας σχεδιάσει το σχήμα, επιλέγουμε το εργαλείο Bone 

2. Ορίζουμε τις αρθρώσεις στο σχήμα (2) 

3. Μπορούμε να τροποποιήσουμε το σχήμα. 

Στην συνέχεια επιλέγουμε το εργαλείο Bind και κάνουμε κλικ. 

4. Αν κάνω κλικ στο οστό, αυτό επισημαίνεται με κόκκινο χρώμα και όλα τα 

συνδεδεμένα σημεία ελέγχου στο σχήμα επισημαίνονται με κίτρινο χρώμα. 

Αν θέλουμε να επαναπροσδιορίσουμε ποιά σημεία ελέγχου συνδέονται στο 

επιλεγμένο οστό,  

 Shift+κλικ, προσθέτει επιπλέον συσχετισμούς σε σημεία ελέγχου. 

 Ctrl+κλικ, αφαιρεί συσχετισμούς από το σημείο ελέγχου. 

 Κλικ στο επιλεγμένο οστό και σέρνω σε σημείο: σύνδεση σημείου με 

οστό. 

5. Αν κάνω κλικ σε ένα συνδεδεμένο σημείο, αυτό επισημαίνεται με κόκκινο χρώμα και 

όλα τα συνδεδεμένα οστά στο σχήμα επισημαίνονται με κίτρινο χρώμα. 

Αν θέλουμε να επαναπροσδιορίσουμε ποια οστά συνδέονται με το επιλεγμένο σημείο 

ελέγχου,  

 Shift+κλικ, προσθέτει επιπλέον συσχετισμούς σε οστά. 

 Ctrl+κλικ, αφαιρεί συσχετισμούς από το οστό. 

 Κλικ στο σημείο ελέγχου και σέρνω σε οστό: σύνδεση σημείου με οστό. 

 

 


